Avrunda och avkorta tal i Excel

I Excel kan du använda funktioner för att avrunda eller avkorta tal på många olika sätt.


Om du använder knapparna Öka decimal eller Minska decimal så kan du visserligen också ”avrunda” ett tal. Men notera att detta är en formatering som ändrar hur talet ser ut inte dess värde. Om du till exempel har minskat decimalen (dvs. klickat på knappen Minska decimal) på talet 2,49 tills att du bara ser siffran 2 och sedan multiplicerar talet med två så kommer resultatet bli 4,98. Om du däremot hade använt funktionen =AVRUNDA(2,49;0)*2 så får du resultatet 4 (eller 4,000 beroende på hur många decimaler du sedan väljer att visa). Knapparna Öka respektive Minska Decimal ger med andra ord bara en visuell avrundning medan funktionerna ger en faktisk avrundning.

Avrundaexempel

Exempel på funktionerna AVRUNDA, AVKORTA, MAVRUNDA och RUNDA.UPP

Det finns flera funktioner som kan avrunda på många olika sätt. Här får du exempel på fyra olika funktioner. I bilden gör alla funktioner en beräkning på cell A2 som innehåller talet 96,129

  • Funktionen AVRUNDA [ROUND] avrundar ett tal till ett angivet antal siffror. =AVRUNDA(A2;2) ger resultatet 96,13.
  • Funktionen AVKORTA [TRUNC] avkortar ett tal till ett heltal genom att ta bort decimaler. =AVKORTA(A2;2) ger resultatet 96,12.
  • Funktionen MAVRUNDA [MROUND] returnerar ett tal avrundat till en given multipel. =MAVRUNDA(A2;5) ger resultatet 95, dvs. avrundar till närmaste 5-tal (tal delbart med 5).
  • RUNDA.UPP returnerar tal som har avrundats uppåt (i riktning från noll) till närmaste signifikanta multipel. =RUNDA.UPP(A2;5) [CEILING] ger resultatet 100. Dvs uppåt till närmaste 5-tal (tal delbart med 5).

Därmed avrundar jag för idag…

Bookmark and Share